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ABSTRACT 

 

One of the main goals of the state policy in the field of information technology is to encourage 

educated and honed young people to join developed countries and contribute to the 

development of our country through the development of new information technologies, 

multimedia didactic tools and new pedagogical technologies. Teaching methods determine the 

direction of the teacher and student in the learning process, the organization and conduct of the 

educational process, as well as the actions of the teacher. These methods include a set of 

methods used by teachers to help students acquire knowledge, skills, and abilities. In the 

educational system, along with teaching methods, the terms “method” and “tool” are used. The 

method consists in working with some elements of another teaching method along with the 

main teaching method used in the transfer of a specific educational material. The tool is the use 

of auxiliary training materials, equipment, weapons, equipment, etc., necessary for the training 

methodology. As a didactic tool for teaching science in higher education, the laboratory plays 

an important role in developing students' interest in science through the gradual introduction 

of materials and their use. It is well known that in higher education, computer science is used 

mainly through practical and laboratory work, creating knowledge, skills and abilities in the 

teaching of natural sciences. With this in mind, this article is devoted to the preparation and 

use of additional materials, which are one of the didactic tools in the lessons ... 
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INTRODUCTION, LITERATURE REVIEW, METHODOLOGY 

 

At present, it is impossible to adapt the education system to the needs of the information age. 

This is also the focus of the National Personnel Training Program. The following should be 

understood as the basis for the necessity of teaching computer disciplines: 

- computers, computer and communication technologies are a product of the global 

information revolution; 

- find ways to bring the computerization of the education system in the Republic of 

Uzbekistan to the international level; 

- The computer is a powerful tool to increase the effectiveness of the educational 

process, as it improves the quality of the provision of educational information, increases 

interest in educational science, increases the ability to make learning interesting and improves 

teaching management methods. Provides a high level of teacher role in the quality of 

information transfer; 

- the presence of a graphical interface, “friendly” means of communication and other 

functions on modern computers allows all professionals and users of all areas to communicate 

freely with a computer; 
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- children are better prepared for the future life and material well-being in a changing 

world as a result of computer literacy; 

- the capabilities of modern computer technologies are so great that they can be used 

not only in education, but also in the education of a fully developed generation.[5] 

 

Based on the knowledge gained, each qualified specialist should be a master of his work and 

be able to use various forms of organization of the lesson during training. The most important 

problem today is the formation of youth as a highly educated, independent person in socio-

political life, who has professional skills and determines the present and future of our country. 

Personality formation is a comprehensive concept, and it also includes education and training. 

 

In this era of the rapid development of science and technology and information flows, there is 

a need to review and improve the school system. In particular, it is becoming increasingly 

apparent that the use of information and communication tools, Internet technologies and the 

provision of their results in lessons and extracurricular activities.[4] 

 

It is important for teachers not only to know the laws of instruction, but also to create favorable 

conditions for their implementation. This can be achieved only if you are well versed in the 

basic principles of training in the organization of the educational process. These rules are called 

didactic or didactic principles. 

 

Didactic principles: organization of training on a scientific basis; his educational status, 

regularity and consistency; Visibility and content of readers activity and awareness of learning; 

thorough development of knowledge, skills and abilities, as well as an individual approach to 

each student. 

 

Instructors should be trained in the design of tools and equipment, the principles of labor and 

labor organization, the achievements of science and technology, so teachers should adhere to 

the following principles. 

 

The principle of the scientific organization of education is the use of technical terms and 

methods to stimulate the educational work of students, develop their mental abilities and teach 

them self-study. 

 

The educational nature of education creates the conditions for students to acquire professional 

knowledge, the development of their mental development and worldview. 

 

In the implementation of education, the teacher should instill in students a love of their 

profession, a disciplined discipline, the ability to plan their work and the ability to work in a 

team. They must be organized in such a way that their views are formed. 

 

The principle of visualization includes the development of live events and the perception of 

what is being studied. The principle of visual education provides a direct perception of 

educational material through clear images. 

 

Use visual aids in the learning process; helps students master scientific knowledge and improve 

their skills.[8] If a visual weapon is a means of representing educational material, speech will 

be the main one, and the visual tool will be auxiliary, you should focus on the main tool, that 

is, to increase the goals and objectives of observation. 
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Expressing the importance of observing, perceiving and perceiving things and events in the 

process of acquiring knowledge, Yu. Komensky wrote: “A sight with an ear must hear what it 

hears, smell and understand what it is possible to feel, it is necessary to feel the presence of 

several senses. To teach, you need to teach everything on the basis of direct observation and 

sensitivity".[2] 

 

This should correspond to the requirements of theoretical courses, posters, videos, special 

materials should be prepared. The principle of educational relevance requires students to 

consider their mental and physical characteristics. 

 

The principles of awareness and activity. Education involves creating creative ways of learning. 

This can be achieved through the active participation of students in the classroom. In this 

process, attention is paid to the intelligence and activity of each student. 

 

The principle of careful preparation. According to this principle, the teacher oversees practical 

laboratory work. To ensure careful planning, the materials studied are regularly updated, new 

materials are strengthened, and training is conducted as follows: 

- Frequent repetition of working methods in order to obtain a strong specialty; 

- To teach students the skills of using technical literature and reference books; 

- the transition from simple exercises to more complex exercises of skill formation and 

conducting classes in the immediate vicinity of production. 

An individual approach to each student requires comprehensive training of students, their 

timely support and the creation of conditions for their initiative and creativity. 

The nag must read each student’s description and interview each of them before the lesson 

begins to take into account their characteristics. 

The correct choice of organizational forms of theoretical and practical training is important. 

The place and schedule of classes, the activities of students and their classification in the 

classroom - all this is about the importance of the relationship between teacher and students. 

 

Teaching methods should be used rationally and effectively to organize and conduct lessons at 

a high level. Teaching methods determine the direction of the teacher and student in the 

learning process, the organization and conduct of the educational process, as well as the actions 

of the teacher. These methods include a set of methods used by teachers to help students acquire 

knowledge, skills, and abilities. 

 

In the educational system, along with teaching methods, the terms “method” and “tool” are 

used. The method consists in working with some elements of another teaching method along 

with the main teaching method used in the transfer of a specific educational material. The tool 

is the use of auxiliary training materials, equipment, weapons, equipment, etc., necessary for 

the training methodology. 

 

Teaching methods will undergo significant changes in the educational process and the 

centuries-old history of pedagogical thinking. Pedagogy does not have the same approach to 

the classification and definition of teaching methods. Some authors consider the characteristics 

of knowledge sources as key in determining teaching methods; for example, oral (interviews, 

explanations, statements, independent work of students with technical literature, etc.); 

Demonstration (demonstration of weapons, showing films, independent monitoring of students, 

etc.); practical (exercises, working methods, practical laboratory exercises) and others. 

Recently, in pedagogical theory and practice, methods have been used to classify students 

according to the state of their cognitive activity. 
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The methods used in the learning process should aim to increase student engagement and 

ensure that students are deeply involved in the learning material that they study. The system of 

methods proposed by I.Ya. Lerner and M.N. Skatkin, fully complies with these requirements. 

The basis of this activity is the cognitive activity of students. I mean: 

 

Explanation is a visual method. The teacher provides students with various tools for reading, 

understanding, and storing information in their memory. The way to remember. Organizes the 

cognitive activity of students according to the system of teaching tasks. The student also has 

visualization skills. As students learn, the use of the first method in combination with others is 

expanding. 

 

Formulation of the problem. The teacher creates a problem situation. Throughout the course, 

he will explain and decide how to solve it. Students are actively involved in solving problems 

with the teacher. Partial research or heuristic method. The teacher points out the learning 

problem, divides it into auxiliary parts and offers students a way to solve it. In this case, the 

teacher will tell students about some areas, such as pre-prepared questions.. 

 

Research method. This is a way of organizing independent research and creative work of 

students in solving new problems. In this case, the teacher will not tell them the problem. 

Students find this in the process of developing educational material, which then creates a 

problem for the teacher. 

 

Traditional teaching methods - oral presentations, explanations, interviews, lectures, reading; 

experiments, demonstration of natural objects, visual aids; exercises, writing, graphic work, 

laboratory work. The methods described are used as tools and techniques, and the teacher uses 

them to teach at a high level in the classroom. 

 

A practical method is a form of educational material based on exercises, independent tasks, 

and practical and laboratory work. In industrial training, this method includes working methods, 

exemplary work on the development of independence in the performance of tasks, as well as 

laboratory and practical classes for managing the management process. 

 

Exercise is the repetition of certain actions to develop and strengthen skills and competencies. 

Attentiveness and expediency are the most important requirements for an exercise, so that 

students have a clear idea of why this exercise is necessary, and actively strive to complete it. 

Ways to follow the scientific and technical foundations of the processes under study, as well 

as knowledge of errors in the work, allow students to master the learned actions. 

 

Awareness and relevance skills are especially important in the early stages of building skills so 

that trainers can help them deal with the problems they face. In order for the exercises to be 

successful, the teacher must support the students' aspirations to achieve the desired results, and 

the exercises should be more complex. 

 

The process of developing skills plays a crucial role in learning activities. Success depends on 

a number of conditions. 

 

The first condition is what is skill? Ability to automate the system of actions. If the reader does 

not understand the importance of the material in its development, these actions can be difficult 

to form. 
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The second condition is an exercise system, which is usually caused by the shortcomings of 

creating and conducting a training system. The third condition is that the student must know 

about his actions and not allow them to perform mechanical and memorable actions. 

 

The fourth condition is careful preparation for initial actions and operations. Skills are faster 

and more successful if operations are performed consciously and systematically. The reader 

should not be mistaken in their initial actions, as there may be problems with re-reading them. 

Initial behavioral errors can be repeated and corrected later, and they can be difficult to correct, 

so it is very useful to say the sequence of operations out loud or not when performing actions. 

The teacher carefully monitors these actions and operations. The fifth condition is self-control 

and self-control. The teacher must teach the student to control this. 

 

The sixth condition is to analyze and evaluate exercises, case studies. There are pros and cons 

to learning skills. Teachers make mistakes and keep students alert.[3] If these skills are fulfilled, 

practical teaching methods will lead to successful learning materials. 

Key factors that contribute and improve established skills and qualifications: 

- conscious strengthening of skills and competencies; 

- rely on the knowledge gained in their formation; 

- prevent mistakes, correct them in a timely manner, that is, prevent unhealthy practices; 

- establish uniform pedagogical requirements for all students; 

- gradually complicate tasks (transition from the simplest working methods to complex 

tasks); 

- proper use of time for exercise; 

- Continuing education to the full development of skills; 

- attentiveness of your students; 

- regular monitoring of exercises.  

 

RESULTS, DISCUSSION 

 

It is well known that the formation of knowledge, skills and abilities in teaching computer 

graphics in higher educational institutions, as well as the acquisition of knowledge and 

knowledge in the field of science. With this in mind, we focus on the preparation and use of 

additional materials, which are one of the didactic tools in the lessons. 

 

Let's see what additional materials for computer graphics should be and how to handle them. 

Additional material on each topic should be developed to strengthen theoretical knowledge and 

provide students with skills and knowledge. Each laboratory task is designed to ensure the 

consistent execution of evolutionary sequences, i.e. step-by-step steps. Then the students will 

be given assignments for independent work .. 

 

Theoretical knowledge obtained from traditional teaching methods is verified by practical 

verification and consolidation of common goals. The use of these additional materials gives 

each student a separate task and consolidates the theoretical knowledge gained. 

The advantages of this approach to learning are as follows: 

- less time for training; 

- ensuring the individual work of students; 

- make sure that the area of computer graphics is wide; 

As an example, consider the following additional material for creating special effects using 

Adobe Photoshop 7. The purpose of choosing this version of Adobe Photoshop is that it does 

not take much time to load and is a simpler version than other versions: 
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LASER NOTE 

Purpose: performing actions such as filter, tone line, channel.[2] 

1. Open Adobe Photoshop.File ► New (<Ctrl>+<N>).  

2. Set the following options:  

 
 

3.   Make the following observation using the Type tool. :  

Font Type: Time New Roman 

Appearance: Bold 

size: 150 pixel 

color: black 

 

 

 
 

4. Center the recording in the center of the image. Move   . 

 
5. Move text to layer Layer ► Rasterize ► Layer. 

6. Next apply filter: Filter ► Artistic ► Plastic Warp... 
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7. Create the following line from the window generated by the sequence: note that the 

line looks like this Image ► Adjustments ► Curves (Ctrl+M)  . 

8.  

 

 
 

9.  Make laser color: Image ► Adjustments  ► Selective Color  

 

 
 

10. In the Layers panel, go to the Background layer and turn the background black 
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11. Go back to the recording layer. 

12. Make the following effect: Layer ► Layer effect ► External light 

 
 

 
 

13. Merge layer (Ctrl+E) 

14. Save the finished image to a folder. [1] 

 

After completing this laboratory work, each student is assigned separate tasks in the same 

sequence. The teacher analyzes the results obtained by partially changing the values of 

individual steps in the process of implementation, and creates knowledge, skills and abilities 

in this subject. 

 

This type of additional material can be regularly used in each lesson, depending on the number 

of subject lessons that will be effectively used in the learning process. This will increase the 

effectiveness of teaching, as well as the gradual implementation of scientific tasks of students 

and motivates them with knowledge and skills.. 

 

CONCLUSIONS 

Thus, based on the above data, laboratory classes in computer science in higher education 

institutions are used in the process of completing assignments. We considered the preparation 

of the aforementioned laboratory tasks in a specific subject, in which the laboratory classes 

consisted of a series of steps, and the result was achieved. After completing this lab assignment, 

each student will be given separate assignments. During the assignment, students will acquire 

the knowledge and skills that they need in science.  
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